Applies to: Risk Assessment Platform
Question
- I used Forgot Password on the login page but didn't receive the email to reset the password. What can I do to reset my password?
- The Reset Password email is not showing up in my inbox. Why?
Answer
There are a number of reasons you may not receive the Forgot Password email:
Inactive Account
Cause
You were invited to the platform but did not activate your account before the invite expired.
or
Your account has been deactivated by the company administrator on the account.
Solution
Email the person who invited you and ask them to send you a new invitation.
Alternatively, email us at Support@arctic-intelligence.com
Email Security Filters
Cause
Spam and phishing filters on your company's mail servers can cause emails from the platform to be sent to the Junk Email folder or be rejected altogether by the mail server. This is especially the case when emails have a subject containing "Reset Password".
In some cases, the email can take up to 20 minutes to reach your Inbox or Junk Email folder while the phishing/spam filters on your mail server verify the email is safe.
Solution
Check your Junk Mail folder. If the email is not there after 20 minutes, you will need to ask your IT team to allow support@arctic-intelligence.com.
Note: Each time you trigger a Reset Password email, previous emails' hyperlinks become invalid.
Wrong Login Page
Cause
If you searched the web to find the login page, you may be on the wrong website.
Solution
Check the address of the login page you're on; it should be https://app.risk-platform.com/
Add this URL to your browser shortcuts or favourites.
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